Аудиторско-Оценочная группа "Реал-Аудит"


О ФИРМЕ arrow Нашим студентам arrow Обработки 1 С-Предприятие
24.09.2017
О ФИРМЕ
АУДИТ
ОЦЕНКА ДЛЯ НОТАРИУСА
ОСПАРИВАНИЕ КАДАСТРОВОЙ СТОИМОСТИ
ОЦЕНКА НЕДВИЖИМОСТИ
ТЕХНОЛОГИЧЕСКИЙ АУДИТ
ЭКСПЕРТИЗА
ОЦЕНКА
БУХГАЛТЕРСКИЕ УСЛУГИ
КОНТАКТЫ
В помощь оценщику
Нашим студентам
Новости аудита
Обмен обработками 1С Версия в формате PDF Версия для печати Отправить на e-mail

Обработка для 1С 8.1.  конфигурация УПП

Загрузка статей Движения денежных средств

 

Процедура ВыборФайла(Элемент, ПроверятьСуществование=Ложь)

 

      

       ДиалогФыбораФайла=Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);

 

       ДиалогФыбораФайла.Фильтр="Файл данных (*.xls)|*.xls";

 

       ДиалогФыбораФайла.Заголовок="Выберите файл";

 

       ДиалогФыбораФайла.ПредварительныйПросмотр=Ложь;

 

       ДиалогФыбораФайла.Расширение="xls";

 

       ДиалогФыбораФайла.ИндексФильтра=0;

 

       ДиалогФыбораФайла.ПолноеИмяФайла=Элемент.Значение;

 

       ДиалогФыбораФайла.ПроверятьСуществованиеФайла=ПроверятьСуществование;

 

       Если ДиалогФыбораФайла.Выбрать() Тогда

 

             Элемент.Значение = ДиалогФыбораФайла.ПолноеИмяФайла;

 

       КонецЕсли;

КонецПроцедуры

 

 

Процедура ИмяФайлаДанныхНачалоВыбора(Элемент, СтандартнаяОбработка)

       ВыборФайла(Элемент);

 

       СтандартнаяОбработка = Ложь;

 

КонецПроцедуры

 

Процедура ИмяФайлаДанныхОткрытие(Элемент, СтандартнаяОбработка)

       ЗапуститьПриложение(Элемент.Значение);

 

КонецПроцедуры

 

Процедура КнопкаВыполнитьНажатие(Кнопка)

 

       Если Организация=Справочники.Организации.ПустаяСсылка() ТОгда

            Предупреждение("Не указана организация!", 10);

              Возврат;

       КонецЕсли;

 

       ИмяФайла =  ИмяФайлаДанных;

 

       Если ПустаяСтрока(ИмяФайла) = Истина Тогда

 

             Предупреждение("Не выбран файл!",4);

 

             Возврат;

 

       КонецЕсли;

 

       xl = Новый COMОбъект("Excel.Application"); 

 

       Книга=xl.Application.Workbooks.Open(ИмяФайла);

 

       ТекЛист=Книга.WorkSheets(1);     

 

      

       номер = 2;

       Пока НЕ (ПустаяСтрока(Строка(ТекЛист.Cells(номер,1).Value)) = Истина И ПустаяСтрока(Строка(ТекЛист.Cells(номер,2).Value)) = Истина И ПустаяСтрока(Строка(ТекЛист.Cells(номер,3).Value)) = Истина И ПустаяСтрока(Строка(ТекЛист.Cells(номер,4).Value)) = Истина И

                    ПустаяСтрока(Строка(ТекЛист.Cells(номер + 1,1).Value)) = Истина И ПустаяСтрока(Строка(ТекЛист.Cells(номер + 1,2).Value)) = Истина И ПустаяСтрока(Строка(ТекЛист.Cells(номер + 1,3).Value)) = Истина И ПустаяСтрока(Строка(ТекЛист.Cells(номер + 1,4).Value)) = Истина) Цикл

 

                   

       Если ПустаяСтрока(Строка(ТекЛист.Cells(номер,4).Value)) = Ложь тогда

                                        Если ВБазеОТсутствует(СокрЛП(Строка(ТекЛист.Cells(номер,3).Value))) ТОгда

 

       Спр = Справочники.СтатьиДвиженияДенежныхСредств.СоздатьЭлемент();

                                               Спр.Наименование = СокрЛП(Строка(ТекЛист.Cells(номер,4).Value));

       Если СокрЛП(Строка(ТекЛист.Cells(номер,5).Value)) = "Оплата труда" тогда

       Спр.ВидДвиженияДенежныхСредств = Перечисления.ВидыДвиженийДенежныхСредств.ОплатаТруда;

                           КонецЕсли;

                           Спр.Записать();

                           НоваяЗапись = РегистрыСведений.СоответствиеКодов.СоздатьМенеджерЗаписи();

                           НоваяЗапись.Организация               = Организация;

                           НоваяЗапись.ОбъектБазы = спр.Ссылка;

                           НоваяЗапись.ОбъектВСтаройБазе   = "ДвиженияДенежныхСредств";

                           НоваяЗапись.КОд=СокрЛП(Строка(ТекЛист.Cells(номер,3).Value));

                           НоваяЗапись.Записать(Истина);

                    КонецЕсли;

             КонецЕсли;

            

             номер = номер +1;

       КонецЦикла;

 

      

 

    xl.Application.Quit();

 

    xl = 0; 

 

    Предупреждение("Загрузка завершена!");

 

 

КонецПроцедуры

 

 

Процедура КоманднаяПанель1ОчиститьСправочник(Кнопка)

      

       выборка = Справочники.СтатьиДвиженияДенежныхСредств.Выбрать();

       Пока выборка.Следующий() цикл

             выборка.ПолучитьОбъект().Удалить();

       КонецЦикла;

      

       Предупреждение("Очистка справочника завершена!");

 

КонецПроцедуры

 

Функция ВБазеОТсутствует(КОдЭлемента)

       Запрос=Новый Запрос;

       Запрос.Текст="ВЫБРАТЬ

                    |      СоответствиеКодов.ОбъектБазы

                    |ИЗ

                    |      РегистрСведений.СоответствиеКодов КАК СоответствиеКодов

                    |ГДЕ

                    |      СоответствиеКодов.Организация = &Организация

                    |      И СоответствиеКодов.ОбъектВСтаройБазе = &ОбъектВСтаройБазе

                    |      И СоответствиеКодов.Код = &Код";

       Запрос.УстановитьПараметр("Организация",Организация);             

       Запрос.УстановитьПараметр("ОбъектВСтаройБазе","ДвиженияДенежныхСредств");             

       Запрос.УстановитьПараметр("Код",КодЭлемента);              

 

       ТЗ=Запрос.Выполнить().Выгрузить();

       Если ТЗ.Количество()=0 ТОгда

             Возврат Истина;

       Иначе 

             Возврат Ложь;

       КонецЕсли;  

КонецФункции

 

 

 

 
Rambler's Top100 Реал-Аудит, ООО в других бизнес-справочниках.
Аудиторская фирма Реал-Аудит
PulsCen.ruБухгалтерский учет, налоговый учет, МСФО в Пензе
Участник каталога